
 
 

 PICASA  TUTORIAL 
 
 

Picasa is a free software program 
from Google  

for organizing and editing digital photos 
 

The following pages make up this tutorial: 
 

 Loading Your Pictures 
The Menu/Tool Bar 

Learning about the Library View 
 Editing in Picasa 

Options Available 
 

 APPENDICES 
 

 Saving Your Photographs in Picasa 
Making a Collage 

 Making a Movie 
Bit’s and Pieces of Other Options in Picasa 

Use Google’s Help 
 

Everything is here from getting you started 
to  

making you an editing genius! 
 

ENJOY! 
 
 
 

LH Camera Club SIG 
Pat Wilkinson –2009 

 
 



Loading Pictures from your Camera, Memory Card, Jump Drive, CD or DVD  etc. 
 

‘I SUGGEST THAT YOU DO NOT USE PICASA TO LOAD YOUR PICTURES’ 
I believe it’s better to keep control of how & where you pictures are loaded. 

 
Before loading any pictures – 

try this very simple method of preparing your computer to receive these images. 
•  Open up my pictures - create & name a folder for these pictures.  Watch where you are 
putting this folder - ‘My Pictures’ is a good place.  Get used to using this area of your 
computer, as Windows has put it there specifically for your images.  You can always move 
them elsewhere later on. But – try and make sure you know where you are saving this 
folder.  Keep this folder open   - - - - - 
 

•  Open up Picasa - (very important).  
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

•  Using whatever type of card reader you 
have - insert your memory card into the 
reader then put the reader into the USB Port. 
‘Windows’ will open a window like this - 
please note exactly what is highlighted and 
checked - checking the box at the bottom 
allows this same window to open each time 
you start to load your images.� 

 
•  Click on the folder and this will happen.  Now, all 
the images on your card are showing - � 
•  On the Toolbar there is a View Icon 
that gives you the option to look at  
your images in different ways.  I  
use details to view because it tells 
me the date I took the images –  
experiment and find what works best for you.  
•  Highlight all of the images – or just the ones you 
want to put into the folder that you have created.  
•  Choose Copy . . . 

•  and Paste into the new folder which is open. - � 
Please note that the images are now in a file I created in  
My Pictures called ‘Picasa Demo Images’.  
•  AND, if you had Picasa open, those images will be in 
Picasa under ‘Picasa Demo Images’.  Now delete & edit to 
your heart’s content!!  Simple as that . . . 
•  Notes:  The memory card shows as a ‘removable disc’ 
in ‘My Computer’ – double click on that icon & the folder 
should open as above.  You do have to disable any ‘Camera 
Protocals’ you may have installed on your computer 
however. 

 

 

 •   Click on this highlighted folder and it will 
�  open a window like this  
 •    DCIM – means Digital Camera Imaging  



PICASA MENU BAR – Take the time to go through each of these drop downs &  
become familiar with all that is available to you. Click on the arrows and discover the 

hidden  
‘goodies’.  Try everything – until you find what works best for you. 

 

 

 

 



 
 
 

•  The Folder List also saves all recent emailed images, - a 
handy way of checking back on what you’ve sent out to people.  
•  Next, Picasa saves all your ‘recently updated’ images – 
which is also handy when you want to check back on a folder 
you were working on last week perhaps.  
•  Next come your folders.  Also, folders containing exported 
& downloaded images (those are images you have taken from 
a website or an email for instance), collections (which you have 
created with several folders), projects & ‘other stuff’ are listed 
in this area.   
•  Locate a particular folder by using the Search Window on 
the top right-hand side of the window. Try working with 
collapsed folders and using the Search function to open the 
folders you wish to work on.  
•  This is what the Folder List looks like when all folders are 
collapsed. Neat and less confusing – at least for me!  �                          

#1.  Folder List – 
•  Go to ‘view’ to set up the list that you 
find works best for you.  I prefer the 
Flat Folder View & sort by Creation 
Date.  The example is showing Tree 
View. 
•  This is a very important work area for 
you as these folders are where all your 
pictures are stored.  REMEMBER – 
these are the folders you made on your 
hard drive, in My Pictures, when you 
loaded your images originally.  
•  The top part is reserved for making 
Albums.  Go to File –New Album in 
the menu bar and create an album name 
– then right click your image and choose 
the album you wish to save the image to.  
•  This creates a ‘folder’ that is ONLY 
in Picasa. If you wish to save this album 
to your hard drive, simply choose the 
album and choose ‘export’ from the 
Output Options list at the bottom of the 
screen.   
 

 
When you open Picasa – this is called the ‘Library View’  
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The quicker you get used to this interface, the easier this program will work for you.  So, spend some 
time finding what works for you – set up this program for what suits your needs.   

If you are having a specific problem – GOOGLE IT!!   

PLEASE REMEMBER PICASA IS LOOKING AT YOUR HARD DRIVE 
IT IS NOT CREATING NEW PICTURES 

 

 



 #2.  the ‘Lightbox’ 
• This is where you open & view all folders 
on your hard drive that contain pictures. So –
when you create a folder in My Pictures 
for a set of images, remember to name it in a 
way that will be easy to search for, both in 
Picasa and on your hard drive.   
• When you load your images from your 
card, scanner, flash drive etc., have Picasa 
Open so the pictures will immediately be 
visible in the ‘Lightbox’.  If you can’t see 
them on the screen, search for the folder 
name you just created by using the small 
search window in the upper right-hand 
corner.  This way you can go through your 
pictures immediately and delete (right click 
and choose ‘delete’) right away.  I review, 
delete and organize all my images this way – 
it’s SO EASY!  Then go on to edit the 
remainder of your images. 

 

#3.  the ‘Picture Tray’                                  ���� 
• On the bottom of your screen you will find the  
‘Picture Tray’ where an image or series of images 
reside while you are working on them.  The tiny 
icons are ‘hold’, ‘clear’ & ‘add to album’ – & are 
for managing the images in the tray. This is also 
where you will gather you images for different 
outputs – see below - �  

 

• The ‘Star, Rotate & Tag’ icons are on top of the panel – the ‘star’ is used to keep track of your very favorite 
pictures & ‘rotate’ allows for changing the orientation, and  ‘tag’ is for naming an image for easier searching.  
 
• ‘Output Options’ icons are next.  First is ‘Upload’ which allows all images in the Picture Tray to be uploaded to 
your own PERSONAL WEB ALBUM – free from Google.            ** See Appendix on Web Albums 
 
• ‘Email’ is next –which allows all images in your Picture Tray to be emailed without worrying about resizing etc. 
Your email program opens up in Picasa and you write you email normally – the picture shows as an attachment.  
The receiver of the email sees your picture in the body of the email and also is able to save the picture 
attachment to their hard drive if they wish. Imagine – emailing your pictures to friends & family the very day you 
take them – anywhere in the world with just a ‘click of the email icon!  (see next page). 
 

output 
options� 

• To ‘Edit’ -double click on the image and it 
will immediately go into the ‘edit mode’ –   � 

More on Editing later - 
• Remember when you edit and save, your 
pictures are saved to your Hard Drive. 
 

 



 
�Upload to your own Web Album        �email to friends & 
family 

 

• To Signup for your very own 
web album, - visit 

 
 

http://picasaweb.google.com.   
 
•  Once you create your 

account, you can upload and share 
your pictures, slide shows and 
movies with friends & family  

•  You have 1G of free storage 
space – plenty of space for your 
treasured photos. 

•  And you can send invitations  
to share you album simply by 

clicking on a link that takes them 
right to your album page.   

**  See Appendex . . . . 

• Print is next - choose image(s) and hold in 
picture tray (click green push-pin icon).  
Choose print icon and Preview/Print window 
will appear –                                               � 
• 1. Choose size of your print (6 available).  
• 2. Choose shrink or crop to fit.   
• 3. Click Border & Captions options if you 
wish to use these. Borders are nice and any 
captions you use will show up if you choose this 
option.  
• 4. Click on Printer – make sure your printer is 
selected.   
• 5. Click on Setup for your printer’s dialogue 
box – choose paper type, print quality & 
orientation. 
• 6. Choose multiple copies or a single print if 
you wish.  
• 7. Review to assure you are using only top-
quality images & that you have the proper 
paper in your printer. 
• NOW - click PRINT  (you may also cancel)  

 
 

• Also – to simplify your life – choose ‘SHOP’ in ‘output 
options’ – and order your prints online – pick them up at  
Wal-Mart or numerous other local stores.  Imagine, in just  
one hour you can have your prints in your hand!!!  

• Time for a quick review – ‘Folder List’ – this is where you will be the most frustrated.  Where is that folder I 
made for ‘Mom’s Birthday Party’ in April?  Well - - how did I name it?  Where was the folder? On my desktop?   
In My Pictures?  In my New Pictures?  In my 2009 Picture Folder?  Where oh where . . .  
  
• FILE MNAGEMENT is the key here.  If you are careful when you first load your pictures, you won’t be 
frustrated!  AND, you have the SEARCH option that usually finds just about anything you’ve lost.  Take a moment 
to think what you’re doing – it will save you hours.  And – a little trick that I use all the time:  when you find a 
picture in Picasa or you’re working in the program and you want to find where that picture is on your hard drive - 
RIGHT CLICK and choose LOCATE ON DISC – and there it is!!!  Try this and get used to it – it’s a lifesaver.

Print Window 

 



    

 

 

Export Option 
• Select the photos you'd like to export to your hard 
drive and click the EXPORT button in the option list. 
• In the 'Export to Folder' window, click on browse & 
select your settings by choosing an export location and 
entering a name for the exported folder. You may 
customize the size and quality if you wish.  I use the 
default. Then click OK – your album becomes a folder!! 
•Reason for doing this? – You’ve created an Album 
(which is only in Picasa) and you want to save all those 
pictures in their own folder permantly.  I do this 
constantly, so I love this nice feature. 

���� Collage  
•  Select the photos you'd like to include in your 
collage.  
•  Click the Collage button in the Options Tray or 
create a Collage for all photos contained in a folder 
or album by clicking the Create Photo Collage 
button located in the folder or album header.  
•  Collage creation page opens - use Settings and 
Clips tabs to control the appearance and content of 
your collage – try shuffle at the bottom of the 
window - play around with all the options – be 
creative & have fun!         **See Appendix 

                  Movie Option                 ���� 
•  Make a movie from your video or your 
images – or both!   
•  Choose your images & click on the 
movie icon & the Movie Maker window 
comes up.      
•  Use the Movie, Slide, and Clips tabs to 
alter movie settings, add text to slides, or 
insert new photos respectively.  
•  Split your video & add images between. 
•  Add captions or text slides 
•  Add an audio track from ‘My Music’  
•  Choose transitions and slide times 
•  Choose your file size – every size from 
cell phone to HD TV. 
•  Make your movie –  
•  Then - upload it to ‘YouTube’ 
•  All this available in Picasa for free! 
 
** See Appendix on Making a Movie 
 

 

And finally – that little slider way over on the right? Well, click on it 
and magnify your images to make sure they are in focus – or to work ‘up 
close & personal’ with your photographs!!  

 
 



 
 
 
 
#4 – MORE OPTIONS AVAILABLE 
 
 
 
 
 
 
 
 
 
 
 
#5 – MORE OPTIONS 
 
 
 
 
 
 
 
 
 
 
 
 
#6 – and More Options 
 
 
 
 
 
 
 
 
 
 
Filters 

 

 

•  Play a Full Screen Slide Show 
•  Create a Photo Collage 
•  Create a Movie Presentation 
•  Create a Gift CD –  

* see Appendix 
•  Shows if Starred Photo present 
•  Add a description for a folder 

•  Upload all edited images to 
their web album automatically. 
•  Share folder on-line 
 
 
 
•  Burn all images or folders 
directly to Disc  

•  Get Photos from a camera, scanner 
or other media 
•  Create a new Album 
•  Folder Structure Views 
•  View Options for above 
•  Capture photos or video from  webcam 
or other video device 

•  Show starred images only 
•  Show uploads to Web Albums only 
•  Show only photos with faces 
•  Show movies only 
•  Filter by date range only 
•  And to the right - SEARCH 

 
 
 
 
 



 
PICASA EDITING 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
TUNING 

•  Crop – several size options are 
available with suggestions –  
•  Straighten – so easy to keep that 
horizon even – 
•  Redeye fix in an instant 
•  Feeling Lucky? Try it – might be all 
you’ll need to make it perfect! 
•  Auto contrast – my favorite 
•  Auto color – be careful here –  
•  Retouch – air-brush wrinkles away  
•  Add Text – will become a big 
favorite – great for greeting cards! 
•  Fill light – use sparingly – works! 
 
Towards bottom right-hand side -  
•  And in the lower right-hand corner 
is the famous Histogram – become 
dependant on it - it’s rarely wrong. (Try 
to keep those ‘mountains’ in the middle). 
 and 
•  Fit image inside viewing area 
•  Display image in actual size.  Good to 
use for checking focus and sharpening. 

•  The Tuning tab allows you to 
adjust the color and lighting in 
your photo. Use the sliders to 
adjust manually or else click the 
magic wands 
•  Add fill light to the foreground 
of photos, making them more 
balanced. 
•  Increase the highlights to 
amplify the bright spots of your 
photograph 
•  Darken the shadows in your 
photo to provide additional depth 
or contrast. 
•  Make your photos warmer by 
sliding the ticker to the right. 
•  Tell Color Picker which part of 
your photo it should treat as gray or 
white. Photo Lab will then use that 
selection to balance the colors in 
the photo.  Try this - it really 
works! 
•  Use all of these carefully & use 
you eye to sense when it’s perfect! 

BASIC FIXES 

 
 



 
   PICASA EDITING cont. 

 

•  The Effects tab contains 12 effects 
that you can apply to any still photo. 
•  Sharpen 
•  Sepia 
•  Black & White 
•  Warmify 
•  Film Grain 
•  Tint 
•  Saturation 
•  Soft Focus 
•  Glow 
•  Filtered B&W 
•  Focal B&W 
•  Graduated Tint 
 
Here’s where the real fun begins! 
Just get in there and play – you can 
always undo – redo – start over. 
Make copies of an image and keep 
trying new things – it’s exciting! 

My favorites are: Sharpen, B&W, 
Soft Focus and Glow. 

   

Well, that’s the basics of Picasa.  Now it’s up to you to find out what Picasa can do for you and your 
photo editing.  It’s my organizer, my simple editor, my email source of sharing pictures and greeting 
cards.  It is my on-line album for sharing happy times and memories with all my friends and family.  It 
stimulates my creativity – even after so many years of using it, Picasa can still surprise me with it 
versatility.   Picasa’s simplicity is the key – and its concise and clear and help tutorials are a welcome 
change from most programs.  I truly hope my tutorial will be of help to you and make your photo 
editing fun and fulfilling – in the easiest way possible. 
   

Editing doesn’t have to be a challenge – Picasa makes it fun!  Enjoy!!! 
 

Pat Wilkinson – pjwcrafts@comline.com 
 

Something important to remember when working in Picasa – if you have an additional editing program 
you use like Photoshop or Elements, Picasa gives you the option of opening your images in that editor 
if you wish.  Choose your image – right click and choose ‘open with’ –  if your image does not open in 
your additional editor – please try the following.  Again, I use this option constantly.   

USING ADDITIONAL EDITORS 

·  To open a photo with another photo application, please do the following: 
·  Right-click (Windows) the desired photo in Picasa or on your hard drive 
·  Select  ‘Open With’ 
·  Select the program you'd like to open. 
·  Your photo will then display in your chosen program 
 

 



‘BITS ‘N PIECES OF OTHER OPTIONS IN PICASA’  
 

Picasa Web Albums 
 
Picasa Web Albums is designed to help users post and share their photos quickly and easily on the web. 
•  To sign up for your own Web Albums, please visit http://picasaweb.google.com 
•  1GB of free storage space to post and share up to  4,000 photos, with the option to upgrade to more space 
•  High-quality photos, automatically resized and optimized to fill available screen space 
•  End-to-end photo management that makes it easy to download uploaded photos back to your computer 

To upload photos from Picasa to your online Web Album, follow these steps: 
•  To sign up for your own Web Albums, please visit http://picasaweb.google.com  
•  Open Picasa. (You can do this by double-clicking the Picasa icon, or by selecting Start > Programs > Picasa.) 
•  Select the photos you want to upload. To select multiple photos, press the Ctrl key while clicking the photos. 
•  Click the Hold button at the bottom of the window. The selected photos appear in the Picture Tray in the lower-
left corner. 
•  Once you've selected all of your photos, click Web Album. 
•  If you're not signed in to your Google Account for Picasa Web Albums, you'll be prompted to sign in. 
•  Select the web album you'd like to add photos to or create a new one. The Upload Manager displays the status 
of the upload. 
•  When the upload is complete, click View Online to launch the album in your browser. 
•  In Web Albums, you can rearrange your photos by clicking Rearrange at the top of the album. 
 
Greeting Cards   
•  How expensive they can be!!  Make one in minutes and send to a friend.   
•  Choose any picture that would be appropriate for your card.  Double click and edit mode will appear - choose 
'TEXT' - just start typing - a border will appear around your text – you can click on it and move the text anywhere 
you wish – change the font type and color – rotate it – make it transparent and etc.   The settings are numerous - 
just have fun and play with them - you can always start over again.  When you're happy with your card – just click 
APPLY - THEN - email it - easy and no cost to you!!!  AND you recipient will be thrilled.  When I find a card I 
really like, I make several copies of it so one is always available for a quick greeting to be sent.  Go to Google 
Help for more information on using the TEXT option. 
 
Gift CD or DVD 
To create a gift CD/DVD, please take the following steps: 
•  Click the Create Gift DB Button in any folder or album header 
•  For more folders or albums, click the Add More button & select those folders you’d like to include. 
•  Adjust your gift CD settings: To resize the photos, choose a new size from the 'Photo Size' drop-down menu. If 
you don't want to resize your photos, choose 'Original Size.' 
•  To include a copy of Picasa, select 'Include Picasa' in step 2. This lets your recipients see the edits you've made 
to the photos when they open Picasa on their computer. You can create a barebones CD by deselecting both 
'Include Slideshow' and 'Include Picasa 
•  To include an auto-running slideshow of your photos, select 'Include Slideshow'. and  photos will be copied in 
the same order that you had the photos arranged in your folder or album.  
•  Name your gift CD/DVD.  
•  Insert a blank disk in you drive -   
•  Click the Burn Disc button – and it’s done in a matter of minutes. 
•  Pop it in a CD Case – give it or mail it – either way it’s full of memories!  



 PICASA – SAVING YOUR PHOTOGRAPHS 
The following may seem confusing – I add it not to confuse but simply to walk you through the various 

ways an image is treated in most editing programs.  Go to Google help for more information. 
I find I use ‘SAVE’ and ‘SAVE AS’ most frequently.  Just remember that Picasa saves your original – 

and don’t stress over all the different options.  You’ll find what works best for you – I promise! 
 
•  Save 
You can use the “Save” option when you want to save changes on an individual picture (or a group of pictures 
that you select). When you save a photo in Picasa, it creates an edited copy of the photo and moves the original 
to a subfolder called “Originals.” The "Originals" subfolder is hidden on your computer and will not be visible in 
Picasa.  This automatic backup allows you to undo or revert your saves. 

To save your edited photo, you'll need to select the photo and then go to “File” > “Save” or ctrl ‘S’ 
 
•  Save Changes 
This “Save Changes” button appears when you have edited a photo in one of your folders. Not only are basic 
fixes and effects considered edits, so are manual rotations of photos as well as automatic EXIF (Exchangeable 
Image File – stores info on the image) rotations performed by Picasa. Whenever a file in Picasa does not look 
the same as it does on disk, the "Save Changes" button will be available.  
 Save Changes” is similar to the “Save” option - it saves your original photo to the “Originals”subfolder 
 
•  Save As 
When you want to create another copy of your photo, you can use “Save As.” The “Save As” feature allows you 
to specify the filename and the location of where you save your photo. It saves a copy of the original, with or 
without the edits applied, into a specified location of your choice, rather than defaulting to the "Originals" folder. 

To use “Save As,” you'll need to select the photo and then go to “File” > “Save As 
 
•  Save a Copy 
The "Save a Copy" is the quickest way to make another copy of your photo. It exports a copy of the original 
photo, including any edits to the folder of the original photo. However, when using "Save a Copy," you will not be 
able to use the resizing options, image quality options, or change the export directory.  The photo will 
automatically be renamed with “-1” to distinguish it from the original. To use those options or to export a group of 
photos use the "Export" button instead. 

To use “Save a Copy,” you'll need to select the photo and then go to “File” > “Save a Copy 
 
Please note: When you save Picasa tries to match the jpeg quality of the original photo. If it can’t match this 
level, the jpeg quality will be saved at 85%. If you are saving a non-jpeg photo, it will be converted and saved as 
a jpeg. 
 
•  How to undo a save 
There are two ways to retrieve the original version of an edited photo: "Undo Save" and "Revert."  "Undo 
Save" brings you back to the original photo with the edits still visible in Picasa, but these edits are no longer 
saved to disk. To undo a save, simply go to the “Edit View” and press the “Undo” button as you would to undo 
any other edit. Reverting a photo will revert your file to its original state, discarding any edits you have made.  

To Revert a photo, go to “File” > “Revert 
 

If you’re unable to undo or revert a saved photo, it’s possible that the original version  
of this photo has been moved.  

To undo or revert a saved photo, it must be saved in the "Originals" subfolder. 
 

REMEMBER - When you save an edited photo in Picasa, it actually copies the original version into a 
hidden subfolder called "Originals." The saved photo is really a copy of the original, with the edits 

applied. This subfolder will not be visible in Picasa, but it will be accessible on your computer. 
 

 FYI – it’s always a good idea to save all your images – old and new – to either an external 
hard drive – a jump drive – or to a CD or DVD.  Picasa offers that option to you – or – it is 
available with Windows.  This way – you always have those images – just in case . . . . . . . 



  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

CONTINUE TO MAKING A MOVIE 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



USE GOOGLE’S HELP 
 

PICASA – Sample of ON-LINE help available. 
Go to ‘HELP’ on the Menu Bar – Picasa will take you right to their website where you type in 
your question and Picasa will answer it simply and concisely- giving you links to continuing 
information related to your topic.   They also have a Blog where people share their experiences 
with the program.  Try it – it’s always available and it’s an easy way to solve a problem.   
 
YouTube is another source for information and ideas.  Googles’ sharing videos program is huge 
and very successful.  Once you create an account with Google for your Web Album, you’ll also 
have the right to use YouTube.  It’s easy – and so much fun.  If you following Googles’ simply 
instructions, you’ll be a star before you know it!!! 
 

AND – still have questions? - there is Google Search on your browser – always a winner! 
 

http://picasa.google.com/support/bin/topic.py?topic=14609&hl=en 

 

 
 

Experiment – try different things – you can always delete and start over.  Don’t forget to upload your 
movie to YouTube – the whole world can watch!!  Good Luck and have FUN!!!! 


